9810 C++ Programming Manual: D:/9810/Cpp Directory Reference

9810 C++ Programming Manual
Cpp Directory Reference

Files

file JY9810Core.h
Generated by doxygen 1.9.1


9810 C++ Programming Manual: D:/9810/Cpp/JY9810Core.h File Reference

Typedefs | Enumerations | Functions
JY9810Core.h File Reference

Typedefs

typedef void * | JY9810_Device_Handle
Windows. More...
typedef unsigned long long | UINT64

Enumerations

enum | JY9810_ReferenceClock { JY9810_Internal = 0 , JY9810_Front_Panel_Clock_In = 1 , JY9810_PXIe_Clk100 = 2 }
enum | JY9810_SampleClockSource { JY9810_InternalClock = 0x0 , JY9810_ExternalClock = 0x1 }
enum | JY9810_Impedance { JY9810_1M_ohm = 0x0 , JY9810_50_ohm = 0x1 }
enum | JY9810_Coupling { JY9810_Coupling_DC = 0x0 , JY9810_Coupling_AC = 0x1 }
enum | JY9810_SampleMode { JY9810_Finite = 0 , JY9810_Continuous = 1 }
enum | JY9810_TriggerType { JY9810_Immediately = 0 , JY9810_Software = 1 , JY9810_Digital = 2 , JY9810_Analog = 3 }
enum | JY9810_TriggerMode { JY9810_StartTrigger = 0 , JY9810_ReferenceTrigger = 1 }
enum | JY9810_DigitalTriggerEdge { JY9810_Rising = 0x0 , JY9810_Falling = 0x1 }
enum JY9810_DigitalTriggerSource {
JY9810_PXI_Trig0 = 8 , JY9810_PXI_Trig1 = 9 , JY9810_PXI_Trig2 = 10 , JY9810_PXI_Trig3 = 11 ,
JY9810_PXI_Trig4 = 12 , JY9810_PXI_Trig5 = 13 , JY9810_PXI_Trig6 = 14 , JY9810_PXI_Trig7 = 15 ,
JY9810_PFI_0 = 16 , JY9810_PXIe_DStarB = 17 , JY9810_PXIe_DStarC = 18
}
enum | JY9810_AnalogWindowCondition { JY9810_Entering = 0x0 , JY9810_Leaving = 0x1 }
enum | JY9810_AnalogTriggerEdge { JY9810_RisingSlope = 0x0 , JY9810_FallingSlope = 0x1 }
enum | JY9810_AnalogTriggerSource { JY9810_Channel_0 = 0 , JY9810_Channel_1 = 1 , JY9810_Channel_2 = 2 , JY9810_Channel_3 = 3 }
enum JY9810_Signal_Source {
JY9810_RM_IN_CONSTANT_0 = 0 , JY9810_RM_IN_PXIE_SYNC100 =1 , JY9810_RM_IN_CONSTANT_1 = 21 , JY9810_RM_IN_ANALOG_Trigger = 6 ,
JY9810_RM_IN_PXITRIGGER0 = 8 , JY9810_RM_IN_PXITRIGGER1 = 9 , JY9810_RM_IN_PXITRIGGER2 = 10 , JY9810_RM_IN_PXITRIGGER3 = 11 ,
JY9810_RM_IN_PXITRIGGER4 = 12 , JY9810_RM_IN_PXITRIGGER5 = 13 , JY9810_RM_IN_PXITRIGGER6 = 14 , JY9810_RM_IN_PXITRIGGER7 = 15 ,
JY9810_RM_FRONT_PANEL_PFI0_IN = 16 , JY9810_StartTrig = 3 , JY9810_ReferenceTrig = 4 , JY9810_AdvanceTrig = 5 ,
JY9810_DSTAR_B = 17 , JY9810_DSTAR_C = 18 , JY9810_PLL_SYNC_TRIGGER_OUT = 22 , JY9810_PLL_SYNC_OUT = 23
}
enum JY9810_Signal_Destination {
JY9810_PXITrig0_OUT = 8 , JY9810_PXITrig1_OUT = 9 , JY9810_PXITrig2_OUT = 10 , JY9810_PXITrig3_OUT = 11 ,
JY9810_PXITrig4_OUT = 12 , JY9810_PXITrig5_OUT = 13 , JY9810_PXITrig6_OUT = 14 , JY9810_PXITrig7_OUT = 15 ,
JY9810_PFI0_OUT = 16 , JY9810_RM_OUT_AI_RX_START_TRIGGER_IN = 3 , JY9810_RM_OUT_AI_RX_REF_TRIGGER_IN = 4 , JY9810_RM_OUT_AIADVANCE_TRIGGER_IN = 5 ,
JY9810_PLL_SYNC_TRIGGER_IN = 0 , JY9810_PLL_SYNC_VALID_OUT = 17 , JY9810_ADC_SYNC_VALID_OUT = 18
}
enum | JY9810_DeviceProperty { JY9810_Independent = 0 , JY9810_MASTER = 1 , JY9810_SLAVE = 3 }

Functions

JY9810API int | JY9810_Open (int slotNumber, JY9810_Device_Handle *hDevice)
Open the 9810 boards using the slot number or the board serial number. More...
JY9810API int | JY9810_OpenByName (const char *cardName, JY9810_Device_Handle *hDevice)
Open the 9810 boards using the board alias name which is set by JYTEK utility JYDM. More...
JY9810API int | JY9810_Close (JY9810_Device_Handle hDevice)
Close the board. More...
JY9810API int | J9810_GetDeviceTemprature (JY9810_Device_Handle hDevice, double *temprature)
get the device temprature. More...
JY9810API int | JY9810_SetDeviceReferenceClock (JY9810_Device_Handle hDevice, JY9810_ReferenceClock clockSource, double clockFrequency)
Set ReferenceClock for the device.There are three ReferenceClock, 10MHz from this device internal or 100MHz from the PXIe chassis or from Front Panel CLK_IN. More...
JY9810API int | JY9810_SetAISampleClkSyncTopology (JY9810_Device_Handle hDevice, JY9810_DeviceProperty devicePrepety)
Set Device Property,this API must be used in Sync function. More...
JY9810API int | JY9810_SetAIStartPointSyncTopology (JY9810_Device_Handle hDevice, JY9810_DeviceProperty devicePrepety)
JY9810API int | JY9810_PLLSyncSendSoftwareTrigger (JY9810_Device_Handle hDevice)
send software sync trigger for master device, only for master clock More...
JY9810API int | JY9810_SignalRouting (JY9810_Device_Handle hDevice, JY9810_Signal_Source sourceSignal, JY9810_Signal_Destination destination)
Route a singal from source to destination. More...
JY9810API int | JY9810_DisconnectSignalRouting (JY9810_Device_Handle hDevice, JY9810_Signal_Source sourceSignal, JY9810_Signal_Destination destination)
Disconnect an established routing. More...
JY9810API int | JY9810_DisableCalibration (JY9810_Device_Handle hDevice, bool disable)
Disable AI calibration coefficient, default false More...
JY9810API int | JY9810_SetDeviceStatusLed (JY9810_Device_Handle hDevice, bool enable, unsigned int frequency)
Control Front Panel Status Led More...
JY9810API int | JY9810_GetDeviceID (JY9810_Device_Handle hDevice, int *deviceID)
Obtain the board ID. More...
JY9810API int | JY9810_GetDeviceSerialNumber (JY9810_Device_Handle hDevice, char *serialNumber, int length)
Obtain the device serialNumber More...
JY9810API int | JY9810_AI_EnableChannel (JY9810_Device_Handle hDevice, unsigned int channelCount, unsigned char *channels, double *lowRegion, double *highRegion, JY9810_Coupling *coupling, JY9810_Impedance *impedance)
Enable AI channels. More...
JY9810API int | JY9810_AI_SetSampleClock (JY9810_Device_Handle hDevice, JY9810_SampleClockSource clockSource, double externalSampelRate)
config PXIe9810 sample clock, Sample Clock Source is defined by enum JY9810_SampleClockSource. More...
JY9810API int | JY9810_AI_SetSampleRate (JY9810_Device_Handle hDevice, double sampleRate, double *actualSampleRate)
Set sampling rate. More...
JY9810API int | JY9810_AI_SetStartTriggerType (JY9810_Device_Handle hDevice, JY9810_TriggerType triggerType)
Set AI start trigger type,the triggerType is defined by enum JY9810_TriggerType. More...
JY9810API int | JY9810_AI_SetDigitalStartTrigger (JY9810_Device_Handle hDevice, JY9810_DigitalTriggerSource triggerSource, JY9810_DigitalTriggerEdge triggerType)
Set AI digital start trigger,the triggerSource is defined by enum JY9810_DigitalTriggerSource, the triggerEdge is defined by enum JY9810_DigitalTriggerEdge. More...
JY9810API int | JY9810_AI_SetAnalogWindowStartTrigger (JY9810_Device_Handle hDevice, JY9810_AnalogTriggerSource triggerSource, JY9810_AnalogWindowCondition triggerCondition, double highThreshold, double lowThreshold)
Set AI analog window start trigger,the triggerSource is defined by enum JY9810_AnalogTriggerSource, the triggerCondition is defined by enum JY9810_AnalogWindowCondition. More...
JY9810API int | JY9810_AI_SetAnalogHysteresisStartTrigger (JY9810_Device_Handle hDevice, JY9810_AnalogTriggerSource triggerSource, JY9810_AnalogTriggerEdge triggerEdge, double highThreshold, double lowThreshold)
Set AI analog hysteresis start trigger,the triggerSource is defined by enum JY9810_AnalogTriggerSource, the triggerEdge is defined by enum JY9810_AnalogTriggerEdge. More...
JY9810API int | JY9810_AI_SetAnalogEdgeStartTrigger (JY9810_Device_Handle hDevice, JY9810_AnalogTriggerSource triggerSource, JY9810_AnalogTriggerEdge triggerEdge, double threshold)
Set AI analog edge window start trigger,the triggerSource is defined by enum JY9810_AnalogTriggerSource, the triggerEdge is defined by enum JY9810_AnalogTriggerEdge. More...
JY9810API int | JY9810_AI_SetReferenceTriggerType (JY9810_Device_Handle hDevice, JY9810_TriggerType triggerType)
Set AI reference trigger type,the triggerType is defined by enum JY9810_TriggerType More...
JY9810API int | JY9810_AI_SetDigitalReferenceTrigger (JY9810_Device_Handle hDevice, JY9810_DigitalTriggerSource triggerSource, JY9810_DigitalTriggerEdge triggerEdge)
Set AI digital reference trigger.the triggerSource is defined by enum JY9810_DigitalTriggerSource, the triggerEdge is defined by enum JY9810_DigitalTriggerEdge. More...
JY9810API int | JY9810_AI_SetAnalogWindowReferenceTrigger (JY9810_Device_Handle hDevice, JY9810_AnalogTriggerSource triggerSource, JY9810_AnalogWindowCondition triggerCondition, double highThreshold, double lowThreshold)
Set AI analog reference trigger,the triggerSource is defined by enum JY9810_AnalogTriggerSource, the triggerCondition is defined by enum JY9810_AnalogTriggerCondition. More...
JY9810API int | JY9810_AI_SetAnalogHysteresisReferenceTrigger (JY9810_Device_Handle hDevice, JY9810_AnalogTriggerSource triggerSource, JY9810_AnalogTriggerEdge triggerEdge, double highThreshold, double lowThreshold)
Set AI analog hysteresis reference trigger,the triggerSource is defined by enum JY9810_AnalogTriggerSource, the triggerEdge is defined by enum JY9810_AnalogTriggerEdge. More...
JY9810API int | JY9810_AI_SetAnalogEdgeReferenceTrigger (JY9810_Device_Handle hDevice, JY9810_AnalogTriggerSource triggerSource, JY9810_AnalogTriggerEdge triggerEdge, double threshold)
Set AI analog edge window reference trigger,the triggerSource is defined by enum JY9810_AnalogTriggerSource, the triggerEdge is defined by enum JY9810_AnalogTriggerEdge. More...
JY9810API int | JY9810_AI_SendSoftTrigger (JY9810_Device_Handle hDevice, JY9810_TriggerMode triggermode)
Send the software trigger signal for AI. More...
JY9810API int | JY9810_AI_SetReTriggerCount (JY9810_Device_Handle hDevice, unsigned long long reTriggerCount)
Set AI retrigger count. More...
JY9810API int | JY9810_AI_SetMode (JY9810_Device_Handle hDevice, JY9810_SampleMode acquisitionMode)
Set AI sampling mode More...
JY9810API int | JY9810_AI_SetPreTriggerSamples (JY9810_Device_Handle hDevice, unsigned int preTriggerSamples)
Set AI pretrigger samples, the samples must greater than 0. More...
JY9810API int | JY9810_AI_SetSamplesToAcquire (JY9810_Device_Handle hDevice, UINT64 samplesToAcquire)
Set AI samples to acquire for each channel in finite mode.The samples range is 1 to 256M samples / channelCount. More...
JY9810API int | JY9810_AI_CommitPLLConfiguration (JY9810_Device_Handle hDevice)
commit the PLL configuration, configure sync if needed More...
JY9810API int | JY9810_AI_Start (JY9810_Device_Handle hDevice)
Start AI acquisition. More...
JY9810API int | JY9810_AI_Stop (JY9810_Device_Handle hDevice)
Stop AI acquisition. More...
JY9810API int | JY9810_AI_CheckBufferStatus (JY9810_Device_Handle hDevice, UINT64 *avaliableSamples, UINT64 *transferedSamples, bool *overrun)
Check AI device buffer status. More...
JY9810API int | JY9810_AI_WaitForAcqComplete (JY9810_Device_Handle hDevice, int timeout, bool *complete)
等待采集完成 More...
JY9810API int | JY9810_AI_ReadStreamData (JY9810_Device_Handle hDevice, unsigned char *dataBuffer, unsigned int dataLength, int timeout, unsigned int *actualReadLength)
Read AI raw data to user defined data buffer. More...
JY9810API int | JY9810_AI_ReadRawData (JY9810_Device_Handle hDevice, short *dataBuffer, unsigned int dataLength, int timeout, unsigned int *actualReadLength)
Read AI raw data to user defined data buffer. More...
JY9810API int | JY9810_AI_ReadData (JY9810_Device_Handle hDevice, double *dataBuffer, int dataLength, int timeout, unsigned int *actualReadLength)
Read AI data to user defined data buffer. More...
JY9810API int | JY9810_AI_ScaleData (JY9810_Device_Handle hDevice, int channelCount, short *rawData, double *scaleData, int dataLength)
Covert raw data to physical data More...

Typedef Documentation

◆ JY9810_Device_Handle

typedef void* JY9810_Device_Handle

Windows.

Linux

◆ UINT64

typedef unsigned long long UINT64

Enumeration Type Documentation

◆ JY9810_AnalogTriggerEdge

enum JY9810_AnalogTriggerEdge
Enumerator
JY9810_RisingSlope | Rsing edge for digital trigger.
JY9810_FallingSlope | Falling edge for digital trigger.

◆ JY9810_AnalogTriggerSource

enum JY9810_AnalogTriggerSource
Enumerator
JY9810_Channel_0 | AI Channel 0 as analog trigger source.
JY9810_Channel_1 | AI Channel 1 as analog trigger source.
JY9810_Channel_2 | AI Channel 2 as analog trigger source.
JY9810_Channel_3 | AI Channel 3 as analog trigger source.

◆ JY9810_AnalogWindowCondition

enum JY9810_AnalogWindowCondition
Enumerator
JY9810_Entering | Analog trigger condition is RisingHysteresis.
JY9810_Leaving | Analog trigger condition is FallingHysteresis.

◆ JY9810_Coupling

enum JY9810_Coupling
Enumerator
JY9810_Coupling_DC | DC Coupling.
JY9810_Coupling_AC | AC Coupling.

◆ JY9810_DeviceProperty

enum JY9810_DeviceProperty
Enumerator
JY9810_Independent | Device as independent.
JY9810_MASTER | Device as master.
JY9810_SLAVE | Device as slave.

◆ JY9810_DigitalTriggerEdge

enum JY9810_DigitalTriggerEdge
Enumerator
JY9810_Rising | Rsing edge for digital trigger.
JY9810_Falling | Falling edge for digital trigger.

◆ JY9810_DigitalTriggerSource

enum JY9810_DigitalTriggerSource
Enumerator
JY9810_PXI_Trig0 | PXI_Trig0 as the digital trigger source.
JY9810_PXI_Trig1 | PXI_Trig1 as the digital trigger source.
JY9810_PXI_Trig2 | PXI_Trig2 as the digital trigger source.
JY9810_PXI_Trig3 | PXI_Trig3 as the digital trigger source.
JY9810_PXI_Trig4 | PXI_Trig4 as the digital trigger source.
JY9810_PXI_Trig5 | PXI_Trig5 as the digital trigger source.
JY9810_PXI_Trig6 | PXI_Trig6 as the digital trigger source.
JY9810_PXI_Trig7 | PXI_Trig7 as the digital trigger source.
JY9810_PFI_0 | Front Panel TRG_IN as the digital trigger source.
JY9810_PXIe_DStarB | PXIe_DStarB as the digital trigger source.
JY9810_PXIe_DStarC | PXIe_DStarC as the digital trigger source.

◆ JY9810_Impedance

enum JY9810_Impedance
Enumerator
JY9810_1M_ohm | 1M ohm
JY9810_50_ohm | 50 ohm

◆ JY9810_ReferenceClock

enum JY9810_ReferenceClock
Enumerator
JY9810_Internal | The onboard 10 MHz as JY9810_ReferenceClock Source.
JY9810_Front_Panel_Clock_In | The CLOCK_IN as JY9810_ReferenceClock Source.
JY9810_PXIe_Clk100 | The PXIe chassis 100MHz as JY9810_ReferenceClock Source.

◆ JY9810_SampleClockSource

enum JY9810_SampleClockSource
Enumerator
JY9810_InternalClock | Internal Clock Source.
JY9810_ExternalClock | External Clock Source.

◆ JY9810_SampleMode

enum JY9810_SampleMode
Enumerator
JY9810_Finite | AI Finite mode.
JY9810_Continuous | AI Continuous mode.

◆ JY9810_Signal_Destination

enum JY9810_Signal_Destination
Enumerator
JY9810_PXITrig0_OUT | PXITrig0 as the signal desition to rout.
JY9810_PXITrig1_OUT | PXITrig1 as the signal desition to rout.
JY9810_PXITrig2_OUT | PXITrig2 as the signal desition to rout.
JY9810_PXITrig3_OUT | PXITrig3 as the signal desition to rout.
JY9810_PXITrig4_OUT | PXITrig4 as the signal desition to rout.
JY9810_PXITrig5_OUT | PXITrig5 as the signal desition to rout.
JY9810_PXITrig6_OUT | PXITrig6 as the signal desition to rout.
JY9810_PXITrig7_OUT | PXITrig7 as the signal desition to rout.
JY9810_PFI0_OUT | Front Panle TRG_OUT the signal desition to rout.
JY9810_RM_OUT_AI_RX_START_TRIGGER_IN |
JY9810_RM_OUT_AI_RX_REF_TRIGGER_IN |
JY9810_RM_OUT_AIADVANCE_TRIGGER_IN |
JY9810_PLL_SYNC_TRIGGER_IN |
JY9810_PLL_SYNC_VALID_OUT |
JY9810_ADC_SYNC_VALID_OUT |

◆ JY9810_Signal_Source

enum JY9810_Signal_Source
Enumerator
JY9810_RM_IN_CONSTANT_0 |
JY9810_RM_IN_PXIE_SYNC100 |
JY9810_RM_IN_CONSTANT_1 |
JY9810_RM_IN_ANALOG_Trigger |
JY9810_RM_IN_PXITRIGGER0 |
JY9810_RM_IN_PXITRIGGER1 |
JY9810_RM_IN_PXITRIGGER2 |
JY9810_RM_IN_PXITRIGGER3 |
JY9810_RM_IN_PXITRIGGER4 |
JY9810_RM_IN_PXITRIGGER5 |
JY9810_RM_IN_PXITRIGGER6 |
JY9810_RM_IN_PXITRIGGER7 |
JY9810_RM_FRONT_PANEL_PFI0_IN |
JY9810_StartTrig | StartTrig as the source signal to rout.
JY9810_ReferenceTrig | ReferenceTrig as the source signal to rout.
JY9810_AdvanceTrig | AdvanceTrig as the source signal to rout.
JY9810_DSTAR_B |
JY9810_DSTAR_C |
JY9810_PLL_SYNC_TRIGGER_OUT |
JY9810_PLL_SYNC_OUT |

◆ JY9810_TriggerMode

enum JY9810_TriggerMode
Enumerator
JY9810_StartTrigger | Start trigger mode.
JY9810_ReferenceTrigger | Reference trigger mode.

◆ JY9810_TriggerType

enum JY9810_TriggerType
Enumerator
JY9810_Immediately | AI Immediately trigger.
JY9810_Software | AI Soft trigger.
JY9810_Digital | AI Digital trigger.
JY9810_Analog | AI Analog trigger.

Function Documentation

◆ J9810_GetDeviceTemprature()

JY9810API int J9810_GetDeviceTemprature | ( | JY9810_Device_Handle | hDevice,
 |  | double * | temprature
 | ) |  |

get the device temprature.

Parameters
hDevice | device handle
temprature | device temprature
Returns
0 if success or other error code

◆ JY9810_AI_CheckBufferStatus()

JY9810API int JY9810_AI_CheckBufferStatus | ( | JY9810_Device_Handle | hDevice,
 |  | UINT64 * | avaliableSamples,
 |  | UINT64 * | transferedSamples,
 |  | bool * | overrun
 | ) |  |

Check AI device buffer status.

Parameters
hDevice | device handle
avaliableSamples | number of samples per channel in the device buffer
transferedSamples | The number of samples that have been transfered from the device buffer (per channel)
overrun | true if overflow, false if not overflow.
Returns
0 if success or other error code

◆ JY9810_AI_CommitPLLConfiguration()

JY9810API int JY9810_AI_CommitPLLConfiguration ( JY9810_Device_Handle hDevice )

commit the PLL configuration, configure sync if needed

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY9810_AI_EnableChannel()

JY9810API int JY9810_AI_EnableChannel | ( | JY9810_Device_Handle | hDevice,
 |  | unsigned int | channelCount,
 |  | unsigned char * | channels,
 |  | double * | lowRegion,
 |  | double * | highRegion,
 |  | JY9810_Coupling * | coupling,
 |  | JY9810_Impedance * | impedance
 | ) |  |

Enable AI channels.

Each channel can be independently configured

Parameters
hDevice | device handle
channelCount | number of channels to be enabled
channels | array[channelCount] containing channel IDs
lowRegion | array[channelCount] of lower limit numbers for each channel,typically in volts.
highRegion | array[channelCount] of higher limit numbers for each channel, typcially in volts.
lowRegion | array[channelCount] of impedance.
highRegion | array[channelCount] of coupling.
Returns
0 if success or other error code

◆ JY9810_AI_ReadData()

JY9810API int JY9810_AI_ReadData | ( | JY9810_Device_Handle | hDevice,
 |  | double * | dataBuffer,
 |  | int | dataLength,
 |  | int | timeout,
 |  | unsigned int * | actualReadLength
 | ) |  |

Read AI data to user defined data buffer.

For the multi-channel acquisition, the data is interleaved in the order defined by JY9810_AI_EnableChannel.

Parameters
hDevice | device handle
dataBuffer | user buffer,the buffer size must be greater than or equal to dataLength*channelCount.
dataLength | number of samples per channel
timeOut | timeout time in microsecond
actualReadLength | returns the number of samples per channel actually read
Returns
0 if success or other error code

◆ JY9810_AI_ReadRawData()

JY9810API int JY9810_AI_ReadRawData | ( | JY9810_Device_Handle | hDevice,
 |  | short * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeout,
 |  | unsigned int * | actualReadLength
 | ) |  |

Read AI raw data to user defined data buffer.

For the multi-channel acquisition, the data is interleaved in the order defined by JY9810_AI_EnableChannel.

Parameters
hDevice | device handle
dataBuffer | user buffer, The size of dataBuffer must be greater than or equal to dataLength*channelCount.
dataLength | number of samples per channel
timeOut | timeout time in microsecond
actualReadLength | return the number of samples per channel actually read
Returns
0 if success or other error code

◆ JY9810_AI_ReadStreamData()

JY9810API int JY9810_AI_ReadStreamData | ( | JY9810_Device_Handle | hDevice,
 |  | unsigned char * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeout,
 |  | unsigned int * | actualReadLength
 | ) |  |

Read AI raw data to user defined data buffer.

Used for record mode. data type : char

Parameters
hDevice | device handle
dataBuffer | user buffer, The size of dataBuffer must be greater than or equal to dataLength*channelCount.
dataLength | total number of bytes to read
timeOut | timeout time in microsecond
actualReadLength | return the number of samples per channel actually read
Returns
0 if success or other error code

◆ JY9810_AI_ScaleData()

JY9810API int JY9810_AI_ScaleData | ( | JY9810_Device_Handle | hDevice,
 |  | int | channelCount,
 |  | short * | rawData,
 |  | double * | scaleData,
 |  | int | dataLength
 | ) |  |

Covert raw data to physical data

Parameters
hDevice | Device handle
channel | channel count
rawData | raw short data
scaleData | scaled data , double
dataLength | number of samples
Returns
0 if success or other error code

◆ JY9810_AI_SendSoftTrigger()

JY9810API int JY9810_AI_SendSoftTrigger | ( | JY9810_Device_Handle | hDevice,
 |  | JY9810_TriggerMode | triggermode
 | ) |  |

Send the software trigger signal for AI.

Parameters
hDevice | device handle
triggerMode | software trigger mode. Options: start trigger or reference trigger.
Returns
0 if success or other error code

◆ JY9810_AI_SetAnalogEdgeReferenceTrigger()

JY9810API int JY9810_AI_SetAnalogEdgeReferenceTrigger | ( | JY9810_Device_Handle | hDevice,
 |  | JY9810_AnalogTriggerSource | triggerSource,
 |  | JY9810_AnalogTriggerEdge | triggerEdge,
 |  | double | threshold
 | ) |  |

Set AI analog edge window reference trigger,the triggerSource is defined by enum JY9810_AnalogTriggerSource, the triggerEdge is defined by enum JY9810_AnalogTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI analog start trigger source,0-3<
triggerCondition | AI analog trigger conditions
threshold | threshold
Returns
0 if success or other error code

◆ JY9810_AI_SetAnalogEdgeStartTrigger()

JY9810API int JY9810_AI_SetAnalogEdgeStartTrigger | ( | JY9810_Device_Handle | hDevice,
 |  | JY9810_AnalogTriggerSource | triggerSource,
 |  | JY9810_AnalogTriggerEdge | triggerEdge,
 |  | double | threshold
 | ) |  |

Set AI analog edge window start trigger,the triggerSource is defined by enum JY9810_AnalogTriggerSource, the triggerEdge is defined by enum JY9810_AnalogTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI analog start trigger source,0-3<
triggerCondition | AI analog trigger conditions
highThreshold | high threshold
lowThreshold | low threshold
Returns
0 if success or other error code

◆ JY9810_AI_SetAnalogHysteresisReferenceTrigger()

JY9810API int JY9810_AI_SetAnalogHysteresisReferenceTrigger | ( | JY9810_Device_Handle | hDevice,
 |  | JY9810_AnalogTriggerSource | triggerSource,
 |  | JY9810_AnalogTriggerEdge | triggerEdge,
 |  | double | highThreshold,
 |  | double | lowThreshold
 | ) |  |

Set AI analog hysteresis reference trigger,the triggerSource is defined by enum JY9810_AnalogTriggerSource, the triggerEdge is defined by enum JY9810_AnalogTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI analog start trigger source,0-3<
triggerCondition | AI analog trigger conditions
highThreshold | high threshold
lowThreshold | low threshold
Returns
0 if success or other error code

◆ JY9810_AI_SetAnalogHysteresisStartTrigger()

JY9810API int JY9810_AI_SetAnalogHysteresisStartTrigger | ( | JY9810_Device_Handle | hDevice,
 |  | JY9810_AnalogTriggerSource | triggerSource,
 |  | JY9810_AnalogTriggerEdge | triggerEdge,
 |  | double | highThreshold,
 |  | double | lowThreshold
 | ) |  |

Set AI analog hysteresis start trigger,the triggerSource is defined by enum JY9810_AnalogTriggerSource, the triggerEdge is defined by enum JY9810_AnalogTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI analog start trigger source,0-3<
triggerCondition | AI analog trigger conditions
highThreshold | high threshold
lowThreshold | low threshold
Returns
0 if success or other error code

◆ JY9810_AI_SetAnalogWindowReferenceTrigger()

JY9810API int JY9810_AI_SetAnalogWindowReferenceTrigger | ( | JY9810_Device_Handle | hDevice,
 |  | JY9810_AnalogTriggerSource | triggerSource,
 |  | JY9810_AnalogWindowCondition | triggerCondition,
 |  | double | highThreshold,
 |  | double | lowThreshold
 | ) |  |

Set AI analog reference trigger,the triggerSource is defined by enum JY9810_AnalogTriggerSource, the triggerCondition is defined by enum JY9810_AnalogTriggerCondition.

Parameters
hDevice | device handle
triggerSource | AI reference trigger source,0-3<
triggerCondition | AI analog trigger conditions
highThreshold | high threshold
lowThreshold | low threshold
Returns
0 if success or other error code

◆ JY9810_AI_SetAnalogWindowStartTrigger()

JY9810API int JY9810_AI_SetAnalogWindowStartTrigger | ( | JY9810_Device_Handle | hDevice,
 |  | JY9810_AnalogTriggerSource | triggerSource,
 |  | JY9810_AnalogWindowCondition | triggerCondition,
 |  | double | highThreshold,
 |  | double | lowThreshold
 | ) |  |

Set AI analog window start trigger,the triggerSource is defined by enum JY9810_AnalogTriggerSource, the triggerCondition is defined by enum JY9810_AnalogWindowCondition.

Parameters
hDevice | device handle
triggerSource | AI analog start trigger source,0-3
triggerCondition | AI analog trigger conditions
highThreshold | high threshold
lowThreshold | low threshold
Returns
0 if success or other error code

◆ JY9810_AI_SetDigitalReferenceTrigger()

JY9810API int JY9810_AI_SetDigitalReferenceTrigger | ( | JY9810_Device_Handle | hDevice,
 |  | JY9810_DigitalTriggerSource | triggerSource,
 |  | JY9810_DigitalTriggerEdge | triggerEdge
 | ) |  |

Set AI digital reference trigger.the triggerSource is defined by enum JY9810_DigitalTriggerSource, the triggerEdge is defined by enum JY9810_DigitalTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI reference trigger source
triggerEdge | AI reference to the trigger edge. Options: rising or falling edge
Returns
0 if success or other error code

◆ JY9810_AI_SetDigitalStartTrigger()

JY9810API int JY9810_AI_SetDigitalStartTrigger | ( | JY9810_Device_Handle | hDevice,
 |  | JY9810_DigitalTriggerSource | triggerSource,
 |  | JY9810_DigitalTriggerEdge | triggerType
 | ) |  |

Set AI digital start trigger,the triggerSource is defined by enum JY9810_DigitalTriggerSource, the triggerEdge is defined by enum JY9810_DigitalTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI digital start trigger source
triggerEdge | AI digital start trigger edge. Options: rising or falling edge
Returns
0 if success or other error code

◆ JY9810_AI_SetMode()

JY9810API int JY9810_AI_SetMode | ( | JY9810_Device_Handle | hDevice,
 |  | JY9810_SampleMode | acquisitionMode
 | ) |  |

Set AI sampling mode

Parameters
hDevice | device handle
mode | AI sampling mode defined by enum JY9810_AI_SampleMode.
Returns
0 if success or other error code

◆ JY9810_AI_SetPreTriggerSamples()

JY9810API int JY9810_AI_SetPreTriggerSamples | ( | JY9810_Device_Handle | hDevice,
 |  | unsigned int | preTriggerSamples
 | ) |  |

Set AI pretrigger samples, the samples must greater than 0.

Parameters
hDevice | device handle
preTriggerSamples | AI pretrigger samples, valid only in reference trigger mode.
Returns
0 if success or other error code

◆ JY9810_AI_SetReferenceTriggerType()

JY9810API int JY9810_AI_SetReferenceTriggerType | ( | JY9810_Device_Handle | hDevice,
 |  | JY9810_TriggerType | triggerType
 | ) |  |

Set AI reference trigger type,the triggerType is defined by enum JY9810_TriggerType

Parameters
hDevice | device handle
triggerType | AI reference trigger type.Options: immediate trigger, software trigger, digital trigger or analog trigger.
Returns
0 if success or other error code

◆ JY9810_AI_SetReTriggerCount()

JY9810API int JY9810_AI_SetReTriggerCount | ( | JY9810_Device_Handle | hDevice,
 |  | unsigned long long | reTriggerCount
 | ) |  |

Set AI retrigger count.

The device will be triggered reTriggerCount times.

Parameters
hDevice | device handle
reTriggerCount | AI retrigger count
Returns
0 if success or other error code

◆ JY9810_AI_SetSampleClock()

JY9810API int JY9810_AI_SetSampleClock | ( | JY9810_Device_Handle | hDevice,
 |  | JY9810_SampleClockSource | clockSource,
 |  | double | externalSampelRate
 | ) |  |

config PXIe9810 sample clock, Sample Clock Source is defined by enum JY9810_SampleClockSource.

if clockSource is External, the signal must connect to CLK_IN terminal.

Parameters
hDevice | device handle
clockSource | sample clock source
externalSampelRate | external sample clock rate
Returns
0 if success or other error code

◆ JY9810_AI_SetSampleRate()

JY9810API int JY9810_AI_SetSampleRate | ( | JY9810_Device_Handle | hDevice,
 |  | double | sampleRate,
 |  | double * | actualSampleRate
 | ) |  |

Set sampling rate.

The sampling rate is the same for all channels.

Parameters
hDevice | device handle
sampleRate | AI sampling rate to be set per channel
actualSampleRate | actual sampling rate set by this device,which may be different from the desired sampleRate.
Returns
0 if success or other error code

◆ JY9810_AI_SetSamplesToAcquire()

JY9810API int JY9810_AI_SetSamplesToAcquire | ( | JY9810_Device_Handle | hDevice,
 |  | UINT64 | samplesToAcquire
 | ) |  |

Set AI samples to acquire for each channel in finite mode.The samples range is 1 to 256M samples / channelCount.

Parameters
hDevice | device handle
sampleToAcquire | AI finite samples to acquire for each channel, samples range:1 to 256M samples / channelCount.
Returns
0 if success or other error code

◆ JY9810_AI_SetStartTriggerType()

JY9810API int JY9810_AI_SetStartTriggerType | ( | JY9810_Device_Handle | hDevice,
 |  | JY9810_TriggerType | triggerType
 | ) |  |

Set AI start trigger type,the triggerType is defined by enum JY9810_TriggerType.

Parameters
hDevice | device handle
triggerType | AI start trigger type. Options:immediate trigger, software trigger, digital trigger or analog trigger.
Returns
0 if success or other error code

◆ JY9810_AI_Start()

JY9810API int JY9810_AI_Start ( JY9810_Device_Handle hDevice )

Start AI acquisition.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY9810_AI_Stop()

JY9810API int JY9810_AI_Stop ( JY9810_Device_Handle hDevice )

Stop AI acquisition.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY9810_AI_WaitForAcqComplete()

JY9810API int JY9810_AI_WaitForAcqComplete | ( | JY9810_Device_Handle | hDevice,
 |  | int | timeout,
 |  | bool * | complete
 | ) |  |

等待采集完成

Parameters
hDevice | Device handle
timeout | 设置超时时间，单位ms
complete | 是否完成
Returns
0：正确；非0：错误码

◆ JY9810_Close()

JY9810API int JY9810_Close ( JY9810_Device_Handle hDevice )

Close the board.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY9810_DisableCalibration()

JY9810API int JY9810_DisableCalibration | ( | JY9810_Device_Handle | hDevice,
 |  | bool | disable
 | ) |  |

Disable AI calibration coefficient, default false

Parameters
hDevice | device handle
DisableCalibration | true if disabled, false if not disabled.
Returns
0 if success or other error code

◆ JY9810_DisconnectSignalRouting()

JY9810API int JY9810_DisconnectSignalRouting | ( | JY9810_Device_Handle | hDevice,
 |  | JY9810_Signal_Source | sourceSignal,
 |  | JY9810_Signal_Destination | destination
 | ) |  |

Disconnect an established routing.

Parameters
hDevice | device handle
source | source of the signal defined by enum JY9810_Source
destination | destination of the signal defined by enum JY9810_Destination
Returns
0 if success or other error code

◆ JY9810_GetDeviceID()

JY9810API int JY9810_GetDeviceID | ( | JY9810_Device_Handle | hDevice,
 |  | int * | deviceID
 | ) |  |

Obtain the board ID.

The PXIe-9810 board ID is Ox9810, PCIe-9810 board ID is OxA817.

Parameters
hDevice | device handle
deviceID | board ID
Returns
0 if success or other error code

◆ JY9810_GetDeviceSerialNumber()

JY9810API int JY9810_GetDeviceSerialNumber | ( | JY9810_Device_Handle | hDevice,
 |  | char * | serialNumber,
 |  | int | length
 | ) |  |

Obtain the device serialNumber

Parameters
hDevice | device handle
serialNumber | Pointer to a buffer receiving the serial number. The length of the serial number is 10.
length | serial Number length ,lenth is 10
Returns
0 if success or other error code

◆ JY9810_Open()

JY9810API int JY9810_Open | ( | int | slotNumber,
 |  | JY9810_Device_Handle * | hDevice
 | ) |  |

Open the 9810 boards using the slot number or the board serial number.

PXIe slot number is predefined by the PXIe chassis. PCIe slot number is defined by the DIP switch. The board serial number is defined by the system starting from 0. It's your responsibility to know the number. For a single board, the serial number is 0.

Parameters
slotNumber | slot number or board serial number
hDevice | device handle. All other functions uses hDevice to represent this device.
Returns
0 if success or other error code

◆ JY9810_OpenByName()

JY9810API int JY9810_OpenByName | ( | const char * | cardName,
 |  | JY9810_Device_Handle * | hDevice
 | ) |  |

Open the 9810 boards using the board alias name which is set by JYTEK utility JYDM.

You can change the name using JYDM.

Parameters
cardName | board alias name
hDevice | device handle
Returns
0 if success or other error code

◆ JY9810_PLLSyncSendSoftwareTrigger()

JY9810API int JY9810_PLLSyncSendSoftwareTrigger ( JY9810_Device_Handle hDevice )

send software sync trigger for master device, only for master clock

Parameters
hDevice
Returns

◆ JY9810_SetAISampleClkSyncTopology()

JY9810API int JY9810_SetAISampleClkSyncTopology | ( | JY9810_Device_Handle | hDevice,
 |  | JY9810_DeviceProperty | devicePrepety
 | ) |  |

Set Device Property,this API must be used in Sync function.

Parameters
hDevice | device handle
devicePrepety | defined by enum JY9810_DeviceProperty
Returns
0 if success or other error code

◆ JY9810_SetAIStartPointSyncTopology()

JY9810API int JY9810_SetAIStartPointSyncTopology | ( | JY9810_Device_Handle | hDevice,
 |  | JY9810_DeviceProperty | devicePrepety
 | ) |  |

◆ JY9810_SetDeviceReferenceClock()

JY9810API int JY9810_SetDeviceReferenceClock | ( | JY9810_Device_Handle | hDevice,
 |  | JY9810_ReferenceClock | clockSource,
 |  | double | clockFrequency
 | ) |  |

Set ReferenceClock for the device.There are three ReferenceClock, 10MHz from this device internal or 100MHz from the PXIe chassis or from Front Panel CLK_IN.

PCIe device not support 100MHz from the PXIe chassis .

Parameters
hDevice | device handle
clkSource | ReferenceClock source defined by enum JY9810_ReferenceClock
Returns
0 if success or other error code

◆ JY9810_SetDeviceStatusLed()

JY9810API int JY9810_SetDeviceStatusLed | ( | JY9810_Device_Handle | hDevice,
 |  | bool | enable,
 |  | unsigned int | frequency
 | ) |  |

Control Front Panel Status Led

Parameters
hDevice | device handle
enable | enable front panel status led blink, true: blink, false: not blink
frequency | when enable is ture, the led blink speed by frequency define
Returns
0 if success or other error code

◆ JY9810_SignalRouting()

JY9810API int JY9810_SignalRouting | ( | JY9810_Device_Handle | hDevice,
 |  | JY9810_Signal_Source | sourceSignal,
 |  | JY9810_Signal_Destination | destination
 | ) |  |

Route a singal from source to destination.

Both source and destination are defined by the corresponding enum JY9810_Signal_Source and JY9810_Signal_Destination. One source signal may be routed to multiple destinations.

Parameters
hDevice | device handle
sourceSignal | source of the signal defined by enum JY9810_Source
destination | destination of the signal defined by enum JY9810_Destination
Returns
0 if success or other error code


9810 C++ Programming Manual: D: Directory Reference

  • D:
D: Directory Reference

Directories

directory 9810


9810 C++ Programming Manual: D:/9810 Directory Reference

  • D:
  • 9810
9810 Directory Reference

Directories

directory Cpp


9810 C++ Programming Manual: File List

File List
Here is a list of all files with brief descriptions:
[detail level 1234]
▼ D:
▼ 9810
▼ Cpp
JY9810Core.h


9810 C++ Programming Manual: File Members

Here is a list of all file members with links to the files they belong to:

- j -

  • J9810_GetDeviceTemprature() : JY9810Core.h
  • JY9810_1M_ohm : JY9810Core.h
  • JY9810_50_ohm : JY9810Core.h
  • JY9810_ADC_SYNC_VALID_OUT : JY9810Core.h
  • JY9810_AdvanceTrig : JY9810Core.h
  • JY9810_AI_CheckBufferStatus() : JY9810Core.h
  • JY9810_AI_CommitPLLConfiguration() : JY9810Core.h
  • JY9810_AI_EnableChannel() : JY9810Core.h
  • JY9810_AI_ReadData() : JY9810Core.h
  • JY9810_AI_ReadRawData() : JY9810Core.h
  • JY9810_AI_ReadStreamData() : JY9810Core.h
  • JY9810_AI_ScaleData() : JY9810Core.h
  • JY9810_AI_SendSoftTrigger() : JY9810Core.h
  • JY9810_AI_SetAnalogEdgeReferenceTrigger() : JY9810Core.h
  • JY9810_AI_SetAnalogEdgeStartTrigger() : JY9810Core.h
  • JY9810_AI_SetAnalogHysteresisReferenceTrigger() : JY9810Core.h
  • JY9810_AI_SetAnalogHysteresisStartTrigger() : JY9810Core.h
  • JY9810_AI_SetAnalogWindowReferenceTrigger() : JY9810Core.h
  • JY9810_AI_SetAnalogWindowStartTrigger() : JY9810Core.h
  • JY9810_AI_SetDigitalReferenceTrigger() : JY9810Core.h
  • JY9810_AI_SetDigitalStartTrigger() : JY9810Core.h
  • JY9810_AI_SetMode() : JY9810Core.h
  • JY9810_AI_SetPreTriggerSamples() : JY9810Core.h
  • JY9810_AI_SetReferenceTriggerType() : JY9810Core.h
  • JY9810_AI_SetReTriggerCount() : JY9810Core.h
  • JY9810_AI_SetSampleClock() : JY9810Core.h
  • JY9810_AI_SetSampleRate() : JY9810Core.h
  • JY9810_AI_SetSamplesToAcquire() : JY9810Core.h
  • JY9810_AI_SetStartTriggerType() : JY9810Core.h
  • JY9810_AI_Start() : JY9810Core.h
  • JY9810_AI_Stop() : JY9810Core.h
  • JY9810_AI_WaitForAcqComplete() : JY9810Core.h
  • JY9810_Analog : JY9810Core.h
  • JY9810_AnalogTriggerEdge : JY9810Core.h
  • JY9810_AnalogTriggerSource : JY9810Core.h
  • JY9810_AnalogWindowCondition : JY9810Core.h
  • JY9810_Channel_0 : JY9810Core.h
  • JY9810_Channel_1 : JY9810Core.h
  • JY9810_Channel_2 : JY9810Core.h
  • JY9810_Channel_3 : JY9810Core.h
  • JY9810_Close() : JY9810Core.h
  • JY9810_Continuous : JY9810Core.h
  • JY9810_Coupling : JY9810Core.h
  • JY9810_Coupling_AC : JY9810Core.h
  • JY9810_Coupling_DC : JY9810Core.h
  • JY9810_Device_Handle : JY9810Core.h
  • JY9810_DeviceProperty : JY9810Core.h
  • JY9810_Digital : JY9810Core.h
  • JY9810_DigitalTriggerEdge : JY9810Core.h
  • JY9810_DigitalTriggerSource : JY9810Core.h
  • JY9810_DisableCalibration() : JY9810Core.h
  • JY9810_DisconnectSignalRouting() : JY9810Core.h
  • JY9810_DSTAR_B : JY9810Core.h
  • JY9810_DSTAR_C : JY9810Core.h
  • JY9810_Entering : JY9810Core.h
  • JY9810_ExternalClock : JY9810Core.h
  • JY9810_Falling : JY9810Core.h
  • JY9810_FallingSlope : JY9810Core.h
  • JY9810_Finite : JY9810Core.h
  • JY9810_Front_Panel_Clock_In : JY9810Core.h
  • JY9810_GetDeviceID() : JY9810Core.h
  • JY9810_GetDeviceSerialNumber() : JY9810Core.h
  • JY9810_Immediately : JY9810Core.h
  • JY9810_Impedance : JY9810Core.h
  • JY9810_Independent : JY9810Core.h
  • JY9810_Internal : JY9810Core.h
  • JY9810_InternalClock : JY9810Core.h
  • JY9810_Leaving : JY9810Core.h
  • JY9810_MASTER : JY9810Core.h
  • JY9810_Open() : JY9810Core.h
  • JY9810_OpenByName() : JY9810Core.h
  • JY9810_PFI0_OUT : JY9810Core.h
  • JY9810_PFI_0 : JY9810Core.h
  • JY9810_PLL_SYNC_OUT : JY9810Core.h
  • JY9810_PLL_SYNC_TRIGGER_IN : JY9810Core.h
  • JY9810_PLL_SYNC_TRIGGER_OUT : JY9810Core.h
  • JY9810_PLL_SYNC_VALID_OUT : JY9810Core.h
  • JY9810_PLLSyncSendSoftwareTrigger() : JY9810Core.h
  • JY9810_PXI_Trig0 : JY9810Core.h
  • JY9810_PXI_Trig1 : JY9810Core.h
  • JY9810_PXI_Trig2 : JY9810Core.h
  • JY9810_PXI_Trig3 : JY9810Core.h
  • JY9810_PXI_Trig4 : JY9810Core.h
  • JY9810_PXI_Trig5 : JY9810Core.h
  • JY9810_PXI_Trig6 : JY9810Core.h
  • JY9810_PXI_Trig7 : JY9810Core.h
  • JY9810_PXIe_Clk100 : JY9810Core.h
  • JY9810_PXIe_DStarB : JY9810Core.h
  • JY9810_PXIe_DStarC : JY9810Core.h
  • JY9810_PXITrig0_OUT : JY9810Core.h
  • JY9810_PXITrig1_OUT : JY9810Core.h
  • JY9810_PXITrig2_OUT : JY9810Core.h
  • JY9810_PXITrig3_OUT : JY9810Core.h
  • JY9810_PXITrig4_OUT : JY9810Core.h
  • JY9810_PXITrig5_OUT : JY9810Core.h
  • JY9810_PXITrig6_OUT : JY9810Core.h
  • JY9810_PXITrig7_OUT : JY9810Core.h
  • JY9810_ReferenceClock : JY9810Core.h
  • JY9810_ReferenceTrig : JY9810Core.h
  • JY9810_ReferenceTrigger : JY9810Core.h
  • JY9810_Rising : JY9810Core.h
  • JY9810_RisingSlope : JY9810Core.h
  • JY9810_RM_FRONT_PANEL_PFI0_IN : JY9810Core.h
  • JY9810_RM_IN_ANALOG_Trigger : JY9810Core.h
  • JY9810_RM_IN_CONSTANT_0 : JY9810Core.h
  • JY9810_RM_IN_CONSTANT_1 : JY9810Core.h
  • JY9810_RM_IN_PXIE_SYNC100 : JY9810Core.h
  • JY9810_RM_IN_PXITRIGGER0 : JY9810Core.h
  • JY9810_RM_IN_PXITRIGGER1 : JY9810Core.h
  • JY9810_RM_IN_PXITRIGGER2 : JY9810Core.h
  • JY9810_RM_IN_PXITRIGGER3 : JY9810Core.h
  • JY9810_RM_IN_PXITRIGGER4 : JY9810Core.h
  • JY9810_RM_IN_PXITRIGGER5 : JY9810Core.h
  • JY9810_RM_IN_PXITRIGGER6 : JY9810Core.h
  • JY9810_RM_IN_PXITRIGGER7 : JY9810Core.h
  • JY9810_RM_OUT_AI_RX_REF_TRIGGER_IN : JY9810Core.h
  • JY9810_RM_OUT_AI_RX_START_TRIGGER_IN : JY9810Core.h
  • JY9810_RM_OUT_AIADVANCE_TRIGGER_IN : JY9810Core.h
  • JY9810_SampleClockSource : JY9810Core.h
  • JY9810_SampleMode : JY9810Core.h
  • JY9810_SetAISampleClkSyncTopology() : JY9810Core.h
  • JY9810_SetAIStartPointSyncTopology() : JY9810Core.h
  • JY9810_SetDeviceReferenceClock() : JY9810Core.h
  • JY9810_SetDeviceStatusLed() : JY9810Core.h
  • JY9810_Signal_Destination : JY9810Core.h
  • JY9810_Signal_Source : JY9810Core.h
  • JY9810_SignalRouting() : JY9810Core.h
  • JY9810_SLAVE : JY9810Core.h
  • JY9810_Software : JY9810Core.h
  • JY9810_StartTrig : JY9810Core.h
  • JY9810_StartTrigger : JY9810Core.h
  • JY9810_TriggerMode : JY9810Core.h
  • JY9810_TriggerType : JY9810Core.h

- u -

  • UINT64 : JY9810Core.h


9810 C++ Programming Manual: File Members

  • JY9810_AnalogTriggerEdge : JY9810Core.h
  • JY9810_AnalogTriggerSource : JY9810Core.h
  • JY9810_AnalogWindowCondition : JY9810Core.h
  • JY9810_Coupling : JY9810Core.h
  • JY9810_DeviceProperty : JY9810Core.h
  • JY9810_DigitalTriggerEdge : JY9810Core.h
  • JY9810_DigitalTriggerSource : JY9810Core.h
  • JY9810_Impedance : JY9810Core.h
  • JY9810_ReferenceClock : JY9810Core.h
  • JY9810_SampleClockSource : JY9810Core.h
  • JY9810_SampleMode : JY9810Core.h
  • JY9810_Signal_Destination : JY9810Core.h
  • JY9810_Signal_Source : JY9810Core.h
  • JY9810_TriggerMode : JY9810Core.h
  • JY9810_TriggerType : JY9810Core.h


9810 C++ Programming Manual: File Members

- j -

  • JY9810_1M_ohm : JY9810Core.h
  • JY9810_50_ohm : JY9810Core.h
  • JY9810_ADC_SYNC_VALID_OUT : JY9810Core.h
  • JY9810_AdvanceTrig : JY9810Core.h
  • JY9810_Analog : JY9810Core.h
  • JY9810_Channel_0 : JY9810Core.h
  • JY9810_Channel_1 : JY9810Core.h
  • JY9810_Channel_2 : JY9810Core.h
  • JY9810_Channel_3 : JY9810Core.h
  • JY9810_Continuous : JY9810Core.h
  • JY9810_Coupling_AC : JY9810Core.h
  • JY9810_Coupling_DC : JY9810Core.h
  • JY9810_Digital : JY9810Core.h
  • JY9810_DSTAR_B : JY9810Core.h
  • JY9810_DSTAR_C : JY9810Core.h
  • JY9810_Entering : JY9810Core.h
  • JY9810_ExternalClock : JY9810Core.h
  • JY9810_Falling : JY9810Core.h
  • JY9810_FallingSlope : JY9810Core.h
  • JY9810_Finite : JY9810Core.h
  • JY9810_Front_Panel_Clock_In : JY9810Core.h
  • JY9810_Immediately : JY9810Core.h
  • JY9810_Independent : JY9810Core.h
  • JY9810_Internal : JY9810Core.h
  • JY9810_InternalClock : JY9810Core.h
  • JY9810_Leaving : JY9810Core.h
  • JY9810_MASTER : JY9810Core.h
  • JY9810_PFI0_OUT : JY9810Core.h
  • JY9810_PFI_0 : JY9810Core.h
  • JY9810_PLL_SYNC_OUT : JY9810Core.h
  • JY9810_PLL_SYNC_TRIGGER_IN : JY9810Core.h
  • JY9810_PLL_SYNC_TRIGGER_OUT : JY9810Core.h
  • JY9810_PLL_SYNC_VALID_OUT : JY9810Core.h
  • JY9810_PXI_Trig0 : JY9810Core.h
  • JY9810_PXI_Trig1 : JY9810Core.h
  • JY9810_PXI_Trig2 : JY9810Core.h
  • JY9810_PXI_Trig3 : JY9810Core.h
  • JY9810_PXI_Trig4 : JY9810Core.h
  • JY9810_PXI_Trig5 : JY9810Core.h
  • JY9810_PXI_Trig6 : JY9810Core.h
  • JY9810_PXI_Trig7 : JY9810Core.h
  • JY9810_PXIe_Clk100 : JY9810Core.h
  • JY9810_PXIe_DStarB : JY9810Core.h
  • JY9810_PXIe_DStarC : JY9810Core.h
  • JY9810_PXITrig0_OUT : JY9810Core.h
  • JY9810_PXITrig1_OUT : JY9810Core.h
  • JY9810_PXITrig2_OUT : JY9810Core.h
  • JY9810_PXITrig3_OUT : JY9810Core.h
  • JY9810_PXITrig4_OUT : JY9810Core.h
  • JY9810_PXITrig5_OUT : JY9810Core.h
  • JY9810_PXITrig6_OUT : JY9810Core.h
  • JY9810_PXITrig7_OUT : JY9810Core.h
  • JY9810_ReferenceTrig : JY9810Core.h
  • JY9810_ReferenceTrigger : JY9810Core.h
  • JY9810_Rising : JY9810Core.h
  • JY9810_RisingSlope : JY9810Core.h
  • JY9810_RM_FRONT_PANEL_PFI0_IN : JY9810Core.h
  • JY9810_RM_IN_ANALOG_Trigger : JY9810Core.h
  • JY9810_RM_IN_CONSTANT_0 : JY9810Core.h
  • JY9810_RM_IN_CONSTANT_1 : JY9810Core.h
  • JY9810_RM_IN_PXIE_SYNC100 : JY9810Core.h
  • JY9810_RM_IN_PXITRIGGER0 : JY9810Core.h
  • JY9810_RM_IN_PXITRIGGER1 : JY9810Core.h
  • JY9810_RM_IN_PXITRIGGER2 : JY9810Core.h
  • JY9810_RM_IN_PXITRIGGER3 : JY9810Core.h
  • JY9810_RM_IN_PXITRIGGER4 : JY9810Core.h
  • JY9810_RM_IN_PXITRIGGER5 : JY9810Core.h
  • JY9810_RM_IN_PXITRIGGER6 : JY9810Core.h
  • JY9810_RM_IN_PXITRIGGER7 : JY9810Core.h
  • JY9810_RM_OUT_AI_RX_REF_TRIGGER_IN : JY9810Core.h
  • JY9810_RM_OUT_AI_RX_START_TRIGGER_IN : JY9810Core.h
  • JY9810_RM_OUT_AIADVANCE_TRIGGER_IN : JY9810Core.h
  • JY9810_SLAVE : JY9810Core.h
  • JY9810_Software : JY9810Core.h
  • JY9810_StartTrig : JY9810Core.h
  • JY9810_StartTrigger : JY9810Core.h


9810 C++ Programming Manual: File Members

- j -

  • J9810_GetDeviceTemprature() : JY9810Core.h
  • JY9810_AI_CheckBufferStatus() : JY9810Core.h
  • JY9810_AI_CommitPLLConfiguration() : JY9810Core.h
  • JY9810_AI_EnableChannel() : JY9810Core.h
  • JY9810_AI_ReadData() : JY9810Core.h
  • JY9810_AI_ReadRawData() : JY9810Core.h
  • JY9810_AI_ReadStreamData() : JY9810Core.h
  • JY9810_AI_ScaleData() : JY9810Core.h
  • JY9810_AI_SendSoftTrigger() : JY9810Core.h
  • JY9810_AI_SetAnalogEdgeReferenceTrigger() : JY9810Core.h
  • JY9810_AI_SetAnalogEdgeStartTrigger() : JY9810Core.h
  • JY9810_AI_SetAnalogHysteresisReferenceTrigger() : JY9810Core.h
  • JY9810_AI_SetAnalogHysteresisStartTrigger() : JY9810Core.h
  • JY9810_AI_SetAnalogWindowReferenceTrigger() : JY9810Core.h
  • JY9810_AI_SetAnalogWindowStartTrigger() : JY9810Core.h
  • JY9810_AI_SetDigitalReferenceTrigger() : JY9810Core.h
  • JY9810_AI_SetDigitalStartTrigger() : JY9810Core.h
  • JY9810_AI_SetMode() : JY9810Core.h
  • JY9810_AI_SetPreTriggerSamples() : JY9810Core.h
  • JY9810_AI_SetReferenceTriggerType() : JY9810Core.h
  • JY9810_AI_SetReTriggerCount() : JY9810Core.h
  • JY9810_AI_SetSampleClock() : JY9810Core.h
  • JY9810_AI_SetSampleRate() : JY9810Core.h
  • JY9810_AI_SetSamplesToAcquire() : JY9810Core.h
  • JY9810_AI_SetStartTriggerType() : JY9810Core.h
  • JY9810_AI_Start() : JY9810Core.h
  • JY9810_AI_Stop() : JY9810Core.h
  • JY9810_AI_WaitForAcqComplete() : JY9810Core.h
  • JY9810_Close() : JY9810Core.h
  • JY9810_DisableCalibration() : JY9810Core.h
  • JY9810_DisconnectSignalRouting() : JY9810Core.h
  • JY9810_GetDeviceID() : JY9810Core.h
  • JY9810_GetDeviceSerialNumber() : JY9810Core.h
  • JY9810_Open() : JY9810Core.h
  • JY9810_OpenByName() : JY9810Core.h
  • JY9810_PLLSyncSendSoftwareTrigger() : JY9810Core.h
  • JY9810_SetAISampleClkSyncTopology() : JY9810Core.h
  • JY9810_SetAIStartPointSyncTopology() : JY9810Core.h
  • JY9810_SetDeviceReferenceClock() : JY9810Core.h
  • JY9810_SetDeviceStatusLed() : JY9810Core.h
  • JY9810_SignalRouting() : JY9810Core.h


9810 C++ Programming Manual: File Members

  • JY9810_Device_Handle : JY9810Core.h
  • UINT64 : JY9810Core.h


9810 C++ Programming Manual: Main Page

9810 C++ Programming Manual Documentation